'nx-7k'에 해당되는 글 2건

  1. 2013.02.27 Nexus 스위치로 전환 시, 이슈 - 2 (1)
  2. 2012.09.09 Cisco Nexus - NX-OS 정리 Part 10 (Port Channel)

지난 번, Proxy-arp에 이어서 이번 포스팅도 기존 6500 스위치에서 Nexus로 변경 후에 발생했었던 이슈에 대한 정리입니다.

이번 정리 내용은 Routing 프로토콜에 관한 부분입니다.

 

 먼저 전체적인 간략한 구성을 보면 다음과 같습니다. 지난 번 구성과 거의 같지만, 다른 이슈이기 때문에 하단 구성이 다릅니다.

 

 

 

작업 전, 구성은 이렇습니다.

간략하게 OSPF 설정도 포함했습니다. 동일 네트워크 대역에 대해서 단순히 network 선언해서 현재 통신 중인 상태입니다.

그 상태에서 아래와 같이 6500스위치의 전원을 내리고 나니 아래와 같은 로그가 3750 스위치에서 발생을 하기 시작합니다.

 

 

저런 식의 로그가 지속적으로 올라오면서, 정상적으로 Neighbor를 맺지 못하고 있었습니다.

 

6500장비의 전원을 내리자마자, 바로 왜 저런 문제가 발생을 했을까요?

 

 그것은 vPC 구성 시에, Routing Protocol에 의한 Neighbr 맺는 부분에 대해서 구성이 가능한 Design과 구성이 불가능한 Design이 존재하기 때문입니다. 이전 포스팅에서 간략하게 그 부분에 대해서도 정리가 되어 있긴 하지만, 전체적으로 다시 좀 더 자세하게 정리해서 포스팅 할 예정입니다.

 

여기서 간략하게 2줄로 정리를 하면,

 

• vPC Domain상에서 Layer 2 Port-channel을 통해서 RouterRouting 연결을 하려고 할 경우에 neighbor를 맺을 때 vPC

 Peer들과의  neighbor를 직접 맺지 못하고, 각각의 Peer와 연결된 vPC Port로 분산되서 통신을 하기 때문에 정상적인 neighbor

 을 맺을 수 없다.

 

그렇다면, 6500을 끄기 전에는 왜 저런 문제가 발생하지 않았을까요?

이미 기존 OSPF 구성에서는 DR, BDR이 6500 스위치였기 때문입니다. OSPF 구성 시에, DR과 BDR이 이미 존재할 경우에는 그보다 우선순위가 높은 스위치가 추가되더라도, DR과 BDR이 바뀌지 않기 떄문입니다. (OSPF Process를 재기동하지 않는 이상)

 작업 시에, 전원을 내리면서 새롭게 DR과 BDR이 Nexus 스위치로 변경이 되면서 위와 같이 vPC에서 지원이 되지 않는 Layer 3 Design이 만들어 지면서 이상 로그가 발생을 한 것이었습니다.

 

 그럼 저 문제점을 어떻게 해결을 해야 할 것인지요..

Cisco의 vPC관련 문서에서 vPC에서 Routing Protocol과 관련해서 지원되는 Design 중에 가장 권고하는 Design으로 변경을 했습니다. 그래서 구성은 아래와의 구성과 같이 변경 작업을 했습니다.

 

 

 

  Nexus 스위치와 3750 스위치 간의 Link를 Layer 3 Interface로 변경을 하고, ospf를 point-to-point 직접 연결해서 Neighbor을 맺었습니다. 기타 다른 방식으로도 물론 연결이 가능하긴 합니다만, 이러한 Design을 가장 권고하고 있습니다.

  기타 다른 구성 방식에 대한 부분은 위에서도 언급했지만, 다시 포스팅 할 예정입니다.

 

구성을 위와 같이 바꾸고 나서는 물론 지금 정상적으로 잘 운영되고 있습니다.

이 이슈는 Nexus로 전환하는 경우 이외에도 기존 Nexus 운용 중인 상황에서 Routing Protocol을 운영하는 장비를 추가로 붙이게 될 때도 고려해야 하는 이슈이기 때문에 구성을 잘 고려해서 선택해야 할 것 같습니다.

Posted by 네떡지기

중간에 휴가도 있기도 하거니와 게으르니즘이 계속 발동해서 다시 또 늦어지고 말았네요.
이번 10번째 정리는 Port-Channel에 대한 부분입니다.
아시겠지만, 정리 순서는 공부를 하기 위한 차례는 전혀 아니고 제가 정리를 하는 임의의 순서입니다.
올해 말쯤에는 정리한 것을 하나로 몰아보려고(내용을 좀 더 보완해서...) 생각 중인데.. 잘 될지 모르겠네요..
그럼 내용 중에 이상한 부분이나 보완해야할 부분있으면 지체없이.. 댓글 부탁드립니다. ^^\

Last Updated ('12.09.10)

 


 

Port-Channels

다수의 Port를 묶어서 논리적인 하나의 Port로 인식하게 하는 기술

다수의 Link를 논리적인 하나의 Link로 구성하여 STP에 의한 Blocked 상태를 없애고, 전체 Link Bandwidth 활용 가능.

• Layer 2 Interface, Layer 3 Interface로 구성 가능 (Nexus 7000)

• Nexus 에서는 최대 16개의 Link를 하나의 논리적 Link 구성 가능. (Hardware / Software 영향)

     ※ LaCP 에서 16개의 물리적 Link 하나의 Port-Channel로 구성이 가능하나, 오직 그 중 8 LinkActive  가능.

        (나머지는 Hot-Standby)

     ※ Nexus 7000F1 Module16개를 Link를 하나의 Port-Channel로 구성 가능하며, 또한 16개 모두 Active로 구성 가능.

                            M1 Module16개를 Link를 하나의 Port-Channel로 구성 가능하나, 8개만 Active로 구성 가능.

     ※ Nexus 500016개를 Link를 하나의 Port-Channel로 구성 가능하며, 또한 16개 모두 Active로 구성 가능.

Chassis 528개의 Port-Channels 이 지원된다. (NX-OS 5.2(1) 기준)

• F series 모듈에서는 최대 16개의 Active Port-Channel이 설정된다. (기존 IOS에서는 8)

하나의 Port-ChannelM SeriesF SeriesModulePort를 연결할 수는 없다.

• M Series Module에서 Dedicated PortShared Port를 연결할 수는 없다.

효율적인 부하 분산을 위해서는 2, 4, 8개의 Link로 구성하는 것이 좋으며, 부하분산 알고리즘은 다음과 같이 지정할 수 있다.

     - Source IP, Destination IP, Source MAC, Destination MAC, Source Port, Destination Port

     - Source & Destination IP, Source & Destination MAC, Source & Destination Port

논리적 Interface L2 or L3 모두 설정이 가능하다 

• LACP는 Half-duplex를 지원하지 않으며, Half-duplex로 설정된 것은 suspended가 된다.

• lacp 에서는 ActiivePassive Mode가 있으며, lacp feacture를 활성화 하지 않고, 사용하는 ModeOn 이다.

     - pagp는 지원하지 않음

IOS에서는 port-channel 생성 시에, administratively down이 초기 상태이지만 NX-OS는 생성 직 후, Active 상태가 된다. 

• Server가 연결되는 경우에는 반드시 ModeOn으로 사용해야 한다. (가상화 서버)

 

 

 

Port Channel 설정 및 확인

 

NX-OS(Config)# interface ethernet 1/1 – 1/4                                - Layer 2 Port Channel

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# switchport mode trunk

 

NX-OS(Config)# feature lacp                                                     - Layer 2 Port Channel (LACP)

NX-OS(Config)# interface ethernet 2/1 – 2/4

NX-OS(Config-if-range)# switchport

NX-OS(Config-if-range)# channel-group 2 mode active


NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)# switchport access vlan 2

 

NX-OS(Config)# interface ethernet 3/1 – 3/4                              - Layer 3 Port Channel

NX-OS(Config-if-range)# channel-group 3


NX-OS(Config)# interface port-channel 3

NX-OS(Config-if)# ip address 10.10.3.1/24

 

NX-OS(Config)# feature lacp                                                    - Layer 3 Port Channel (LACP)

NX-OS(Config)# interface ethernet 4/1 – 4/4

NX-OS(Config-if-range)# channel-group 1 mode active


NX-OS(Config)# interface port-channel 4

NX-OS(Config-if)# ip address 10.10.4.1/24

 

 

 

NX-OS# sh port-channel summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port-channel)

        M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-     Type     Protocol      Member Ports

      Channel

--------------------------------------------------------------------------------

1    Po1(SU)      Eth          NONE      Eth1/1(P)    Eth1/2(P)    Eth1/3(P)   Eth1/4(P)

2    Po2(SU)      Eth          LACP       Eth2/1(P)    Eth2/2(P)    Eth2/3(P)   Eth2/4(P)

3    Po3(RU)      Eth          NONE      Eth3/1(P)    Eth3/2(P)    Eth3/3(P)   Eth3/4(P)

4    Po4(RU)      Eth          LACP       Eth4/1(P)    Eth4/2(P)    Eth4/3(P)   Eth4/4(P

 

 

NX-OS# sh port-channel traffic

ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst

------ --------- ------- ------- ------- ------- ------- -------

     1    Eth1/1  55.12%  15.04%  16.22%  21.57%  21.32%  12.82%

     1    Eth1/2  40.58%   2.70%   8.86%  32.55%  21.75%  49.81%

     1    Eth1/3   2.27%  51.05%  46.20%  26.37%  29.18%   6.41%

     1    Eth1/4   2.01%  31.19%  28.69%  19.48%  27.72%  30.94%

------ --------- ------- ------- ------- ------- ------- ------

 

 

 

 

You must remove the port-security information from a port before you can add that port to a port channel. Similarly, you cannot apply the port-security configuration to a port that is a member of a channel group.

Do not configure ports that belong to a port-channel group as private VLAN ports. While a port is part of the private VLAN configuration, the port channel configuration becomes inactive.

Channel member ports cannot be a source or destination SPAN port.

You cannot configure the ports from a F1 and an M1 series linecard in the same port channel because the ports will fail to meet the compatibility requirements.

 

Posted by 네떡지기

티스토리 툴바