'port-channel'에 해당되는 글 2건

  1. 2012.09.09 Cisco Nexus - NX-OS 정리 Part 10 (Port Channel)
  2. 2012.06.09 Cisco Nexus - NX-OS 정리 Part 5 (vPC) (4)

중간에 휴가도 있기도 하거니와 게으르니즘이 계속 발동해서 다시 또 늦어지고 말았네요.
이번 10번째 정리는 Port-Channel에 대한 부분입니다.
아시겠지만, 정리 순서는 공부를 하기 위한 차례는 전혀 아니고 제가 정리를 하는 임의의 순서입니다.
올해 말쯤에는 정리한 것을 하나로 몰아보려고(내용을 좀 더 보완해서...) 생각 중인데.. 잘 될지 모르겠네요..
그럼 내용 중에 이상한 부분이나 보완해야할 부분있으면 지체없이.. 댓글 부탁드립니다. ^^\

Last Updated ('12.09.10)

 


 

Port-Channels

다수의 Port를 묶어서 논리적인 하나의 Port로 인식하게 하는 기술

다수의 Link를 논리적인 하나의 Link로 구성하여 STP에 의한 Blocked 상태를 없애고, 전체 Link Bandwidth 활용 가능.

• Layer 2 Interface, Layer 3 Interface로 구성 가능 (Nexus 7000)

• Nexus 에서는 최대 16개의 Link를 하나의 논리적 Link 구성 가능. (Hardware / Software 영향)

     ※ LaCP 에서 16개의 물리적 Link 하나의 Port-Channel로 구성이 가능하나, 오직 그 중 8 LinkActive  가능.

        (나머지는 Hot-Standby)

     ※ Nexus 7000F1 Module16개를 Link를 하나의 Port-Channel로 구성 가능하며, 또한 16개 모두 Active로 구성 가능.

                            M1 Module16개를 Link를 하나의 Port-Channel로 구성 가능하나, 8개만 Active로 구성 가능.

     ※ Nexus 500016개를 Link를 하나의 Port-Channel로 구성 가능하며, 또한 16개 모두 Active로 구성 가능.

Chassis 528개의 Port-Channels 이 지원된다. (NX-OS 5.2(1) 기준)

• F series 모듈에서는 최대 16개의 Active Port-Channel이 설정된다. (기존 IOS에서는 8)

하나의 Port-ChannelM SeriesF SeriesModulePort를 연결할 수는 없다.

• M Series Module에서 Dedicated PortShared Port를 연결할 수는 없다.

효율적인 부하 분산을 위해서는 2, 4, 8개의 Link로 구성하는 것이 좋으며, 부하분산 알고리즘은 다음과 같이 지정할 수 있다.

     - Source IP, Destination IP, Source MAC, Destination MAC, Source Port, Destination Port

     - Source & Destination IP, Source & Destination MAC, Source & Destination Port

논리적 Interface L2 or L3 모두 설정이 가능하다 

• LACP는 Half-duplex를 지원하지 않으며, Half-duplex로 설정된 것은 suspended가 된다.

• lacp 에서는 ActiivePassive Mode가 있으며, lacp feacture를 활성화 하지 않고, 사용하는 ModeOn 이다.

     - pagp는 지원하지 않음

IOS에서는 port-channel 생성 시에, administratively down이 초기 상태이지만 NX-OS는 생성 직 후, Active 상태가 된다. 

• Server가 연결되는 경우에는 반드시 ModeOn으로 사용해야 한다. (가상화 서버)

 

 

 

Port Channel 설정 및 확인

 

NX-OS(Config)# interface ethernet 1/1 – 1/4                                - Layer 2 Port Channel

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# switchport mode trunk

 

NX-OS(Config)# feature lacp                                                     - Layer 2 Port Channel (LACP)

NX-OS(Config)# interface ethernet 2/1 – 2/4

NX-OS(Config-if-range)# switchport

NX-OS(Config-if-range)# channel-group 2 mode active


NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)# switchport access vlan 2

 

NX-OS(Config)# interface ethernet 3/1 – 3/4                              - Layer 3 Port Channel

NX-OS(Config-if-range)# channel-group 3


NX-OS(Config)# interface port-channel 3

NX-OS(Config-if)# ip address 10.10.3.1/24

 

NX-OS(Config)# feature lacp                                                    - Layer 3 Port Channel (LACP)

NX-OS(Config)# interface ethernet 4/1 – 4/4

NX-OS(Config-if-range)# channel-group 1 mode active


NX-OS(Config)# interface port-channel 4

NX-OS(Config-if)# ip address 10.10.4.1/24

 

 

 

NX-OS# sh port-channel summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port-channel)

        M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-     Type     Protocol      Member Ports

      Channel

--------------------------------------------------------------------------------

1    Po1(SU)      Eth          NONE      Eth1/1(P)    Eth1/2(P)    Eth1/3(P)   Eth1/4(P)

2    Po2(SU)      Eth          LACP       Eth2/1(P)    Eth2/2(P)    Eth2/3(P)   Eth2/4(P)

3    Po3(RU)      Eth          NONE      Eth3/1(P)    Eth3/2(P)    Eth3/3(P)   Eth3/4(P)

4    Po4(RU)      Eth          LACP       Eth4/1(P)    Eth4/2(P)    Eth4/3(P)   Eth4/4(P

 

 

NX-OS# sh port-channel traffic

ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst

------ --------- ------- ------- ------- ------- ------- -------

     1    Eth1/1  55.12%  15.04%  16.22%  21.57%  21.32%  12.82%

     1    Eth1/2  40.58%   2.70%   8.86%  32.55%  21.75%  49.81%

     1    Eth1/3   2.27%  51.05%  46.20%  26.37%  29.18%   6.41%

     1    Eth1/4   2.01%  31.19%  28.69%  19.48%  27.72%  30.94%

------ --------- ------- ------- ------- ------- ------- ------

 

 

 

 

You must remove the port-security information from a port before you can add that port to a port channel. Similarly, you cannot apply the port-security configuration to a port that is a member of a channel group.

Do not configure ports that belong to a port-channel group as private VLAN ports. While a port is part of the private VLAN configuration, the port channel configuration becomes inactive.

Channel member ports cannot be a source or destination SPAN port.

You cannot configure the ports from a F1 and an M1 series linecard in the same port channel because the ports will fail to meet the compatibility requirements.

 

Posted by 네떡지기

Last Update 2014.04.03

 


안녕하세요 

 

Nexus , NX-OS의 5번째 정리내용은 Nexus에서 기존 Port-Channel 기술의 Upgrade 버전인, vPC (virtual Port-Channel)입니다.

 

내용 중에 미흡한 부분도 있을 수 있구요. 혹여나 제가 잘못 이해한 부분이 있을 수 있습니다.

 

그런 경우에는 주저하지 마시고~ 반드시 꼭 댓글 부탁드립니다.

 


 

vPC (Virtual Port Channels)

• vPC는 서로 다른 장비에서 연결된 Port를 묶어서 논리적인 하나의 포트로 인식하게 하는 기존 Port-Channel의 확장된 개념

    - 기존 Port-ChannelLayler-2, Layer-3 모두 설정 가능하지만, vPCLayer-2만 가능하다.

• Spanning Tree를 사용하는 기존의 Port-Channel보다 빠른 Convergence가 가능하다.

• Loop-freeTopology를 제공하기 때문에 Spanning-TreeBlocked Port를 제거할 수 있다.

• feature 명령을 통해서 vPC를 활성화 시켜줘야 한다.

• vPC Domain은 단일 VDC에서만 동작하기 때문에, 반드시 동일한 VDC에서 vPC Domain 선언을 해야한다.

vPCvPC Domain을 통해서, Nexus 장비 간의 연결을 하며, vPC Domain 아래 2개의 특별한 Link를 통해 vPC peers간의 정

  보를 교환한다

    - vPC peer-keepalive link

          : vPC Peer간의 Heartbeating을 제공하여, 장비 간의 Online 상태 확인 vPC 구조에서의 Loop 발생을 피하게 한다.

    - vPC peer link

          : vPC Peer 간의 정보를 교환.

          : vPC Peer-linkLayer 2 port channels(trunk)로 구성하는 것을 권고함.

            ※ vPC peer link 반드시 10GbE Port여야 하며,  서로 다른 2개의 모듈의 포트에 할당해서 설정하도록 한다.

          : 같은 종류의 Line Card간만 구성이 가능하다.          

            Ex) M1 ↔ M1 / F1  ↔  F1 / F2 ↔ F2  [ 구성 가능 ]     

                 M1 ↔ F1 /  M1 ↔ F2 / F1 ↔ F2   [ 구성 불가능 ]

• 서로 다른 장비에서 가상의 vPC를 구성하는 Port-Channel의 Port를 Member Port라고 한다.

    - vPC Member Port

           : NX-OS(config-if) vpc <vpc id>

           : vPC Peer간의 설정이 동일 해야하만 한다. 동일하지 않을 경우 전체 Port가 suspend될 수 있다. (일관성 체크)

           : vPC ID와 Port-Channel ID를 동일하게 구성하는 것이 설정/모니터링/장애처리에 쉽다.

           : 같은 종류의 Line Card간만 구성이 가능하다.          

            Ex) M1 ↔ M1 / F1  ↔  F1 / F2 ↔ F2  [ 구성 가능 ]     

                 M1 ↔ F1 /  M1 ↔ F2 / F1 ↔ F2   [ 구성 불가능 ]

• Cisco Fabric Services (CFS) 자동으로 enable되어, vPC Peer Link를 통해 IGMP, STP, MAC-address-table를 동기화 한다.

 

 

 

peer-keepalive link

• peer-keepalive linkmanagement interface(MGMT0)이나 Switched Virtual Interface(SVI)로 구성이 가능.

• peer-keepalive link는 별도의 VRF사용하여  vPC peer간의 Lavyer 3 인터페이스로 구성하는 것을 권고함.

    - 별도의 VRF를 구성하지 않으면,  시스템에서는 management VRF를 사용함. (Default)

• peer-keepalive link를 관리인터페이스(mgmt0)을 사용할 경우에는, peer 장비에서 Active SupervisiorStandby Supervisior

  각 mgmt0 management switch를 구성해서 연결해야 한다. 

    - mgmt0인터페이스에 직접 바로 연결을 하게 되면, 하드웨어 Fail로 인한 Supervisor switchover,

      In-Service Software Upgrade(ISSU) 동안 mgmt0 인터페이스가 변경됨에 따라서,  keepalive messages  중단될 수 있다.

 

                                 

Mgmt0 인터페이스에 Management Switch를 연결하여 Keepalive-link 구성

 

 

• vPC Peer link를 설정하기 전에 peer-keepalive를 구성해야 한다.

    - 미 구성 시, vPC peer linkpeer linkUp 되지 않는다.

 

 

 

== vPC 설정해보기 예제 ==

 

 

 

 

vPC 설정 (1번기)

 

NX-OS(Config)# feature vpc

 

NX-OS(Config)# vrf context vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/2, 2/2

NX-OS(Config-if)# channel-group 1

 

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# vrf member vPC_Keepalive

NX-OS(Config-if)# ip address 1.1.1.1/30

 

NX-OS(Config)# vpc domain 1

NX-OS(Config-vpc-domain)# peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/1, 2/1

NX-OS(Config-if)# switchport

NX-OS(Config-if)# switchport mode trunk

NX-OS(Config-if)# channel-group 2

 

NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)#  vpc peer-link

 

NX-OS(Config)# interface Ethernet 7/1

NX-OS(Config-if)# channel-group 5 mode active

NX-OS(Config)# interface port-channel 5

NX-OS(Config-if)#  vpc 5

 

NX-OS(Config)# interface Ethernet 7/2

NX-OS(Config-if)# channel-group 6 mode active

NX-OS(Config)# interface port-channel 6

NX-OS(Config-if)#  vpc 6

 

먼저 vPC를 사용하기 위한 feature를 활성화하고, vPC를 구성하는 장비 간의 KeepAlive Link를 구성한다.

그리고 vPC Domain에서 KeepAlive 설정을 하고, vPC 구성 장비(Peer)간의 정보 교환을 위한 Peer Link를 구성한다.

KeepAlive Link와 Peer Link를 모두 구성한 후에는 Port-Channel 생성과 동일하게 Port-Channel 생성 후에

Port-Channel Interface에 vPC를 설정한다.

 

 

 

vPC 설정 (2번기)

 

NX-OS(Config)# feature vpc

 

NX-OS(Config)# vrf context vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/2, 2/2

NX-OS(Config-if)# channel-group 1

 

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# vrf member vPC_Keepalive

NX-OS(Config-if)# ip address 1.1.1.2/30

 

NX-OS(Config)# vpc domain 1

NX-OS(Config-vpc-domain)# peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/1, 2/1

NX-OS(Config-if)# switchport

NX-OS(Config-if)# switchport mode trunk

NX-OS(Config-if)# channel-group 2

 

NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)#  vpc peer-link

 

NX-OS(Config)# interface Ethernet 7/2

NX-OS(Config-if)# channel-group 5 mode active

NX-OS(Config)# interface port-channel 5

NX-OS(Config-if)#  vpc 5

 

NX-OS(Config)# interface Ethernet 7/1

NX-OS(Config-if)# channel-group 6 mode active

NX-OS(Config)# interface port-channel 6

NX-OS(Config-if)#  vpc 6

 

 

 

 

Nexus_정리자료(vPC)update0612.pdf

Posted by 네떡지기

티스토리 툴바