'pinning'에 해당되는 글 2건

  1. 2014.05.21 Nexus : NX-OS Part32(FabricExtender-4)
  2. 2014.04.27 Nexus : NX-OS Part30(FabricExtender-2)

 

이번에는 FEX에 대한 실제 설정과 관련한 부분입니다.

 

 

설정과 관련한 부분도 우선 현재 계획은 이번 포스팅과 다음 포스팅으로 나눠서 진행될 예정이긴 하나,

 

 

더 나눠질지는 아직 모르겠습니다.

 

 

 

 

 

 

 

 


 

FEX 설정 [Static Pinning]

-   Fabric Interface로 사용하게된 Parent Switch에서 Switchport mode를 Fex-fabric 설정을 하고, Fex를 Associate한다.

 

5K-1(config)# install feature-set fex                                                                              fex feature-set 설치

5K-1(config)# feature-set fex                                                                                        fex feature-set 활성화

 

5K-1(config)# int e2/3 

5K-1(config-if)# switchport mode fex-fabric                                                                InterfaceFex Mode 설정

5K-1(config-if)# fex associate 101                                                                                Fex  번호 설정(가상 슬롯 형태)

 

5K-1(config)# int e101/1/1                                                                                           Fex Interface 설정

5K-1(config-if)# switchport mode access                      

5K-1(config-if)# switchport access vlan 10 

 

 

-   Static pinning으로 연결된 포트의 상태 정보이다.

5K-1(config)# sh fex 101 detail

FEX: 101 Description: FEX0101   state: Online

  FEX version: 5.2(1)N1(4) [Switch version: 5.2(1)N1(4)]

  FEX Interim version: 5.2(1)N1(4)

  Switch Interim version: 5.2(1)N1(4)

  

  Pinning-mode: static    Max-links: 1

  Fabric port for control traffic: Eth2/3

   ...

  Fabric interface state:

    Eth2/3 - Interface Up. State: Active

Fex Port        State  Fabric Port

       Eth101/1/1    Up      Eth2/3

       Eth101/1/2  Down      Eth2/3

       Eth101/1/3  Down      Eth2/3

       

      Eth101/1/47  Down      Eth2/3

      Eth101/1/48  Down      Eth2/3 

 

 

-   Static Pinning 시에 상단 Parent Switch와 구성하는 Fabric Interface의 개수를 지정할 수 있는다.

    이 때 해당 FEX 설정 모드에 들어가서 pinning max-link 명령으로 설정을하게 된다. 

5K-1(config)# fex 101

5K-1(config-fex)# pinning max-links  2                                                           [Static Pinning Max Up Link]

 

5K-1(config)# int e2/4                                                                                       2번째 Uplink 설정

5K-1(config-if)# switchport mode fex-fabric                                                     - fabric interface

5K-1(config-if)# fex associate 101 

 

 

-  Mac-link로 설정 후에, 현재의 Fex 상태 정보를 보면 max-link로 설정된 Interface 수에 따라서 Fabric Extender의 포트 구성이

  되어 있음을 볼 수 있다. 아래의 예에서는 2개의 Max-link로 48Port의 Fabric Extender에서 1~24, 25~48 나뉘어서 Fabric Inteface

  가 지정된 것을 확인할 수 있다.

5K-1(config)# sh fex 101 detail

FEX: 101 Description: FEX0101   state: Online

  Pinning-mode: static    Max-links: 2                                                                              Max Uplink 개수

  Fabric port for control traffic: Eth2/3                                                                            FEX Control Traffic 관리 포트

  

  Fabric interface state:  현재 Static PinningPort

    Eth2/3 - Interface Up. State: Active

    Eth2/4 - Interface Up. State: Active

  Fex Port  State  Fabric Port

       Eth101/1/1  Up  Eth2/3

     

      Eth101/1/24  Down   Eth2/3

      Eth101/1/25  Down  Eth2/4

     

      Eth101/1/48  Down  Eth2/4

 

 

-   Static Pinning 상태에서 1개의 Uplink가 Down되었을 때의 상태정보이다.

    Static Pinning 상태에서 Fabric Interface Down시에 각 Port별 재할당에 관련한 내용은 다음 포스팅에서 다뤄질 예정이다.

 

 

 

 

5K-1(config)# sh fex 101 detail

FEX: 101 Description: FEX0101   state: Online

  Pinning-mode: static    Max-links: 2                                                                     Max Uplink 개수

  Fabric port for control traffic: Eth2/4                                                                   FEX Control Traffic 관리 포트

  

  Fabric interface state:                                                                                             현재 Static PinningPort

    Eth2/3 - Interface Down. State: Configured

    Eth2/4 - Interface Up. State: Active

  Fex Port  State  Fabric Port

       Eth101/1/1  Down  Eth2/3

     

      Eth101/1/24  Down   Eth2/3

      Eth101/1/25  Down  Eth2/4

     

      Eth101/1/48  Down  Eth2/4

 

 

 

 

FEX 설정 [Port-Channel]

-  Port-Channel로  FEX 설정은 Static Pinning과 거의 동일하나 Fabric Interface를 Port-channel로 만들고,

   해당 Port-Channel에서 Switchport mode를 Fex-fabric 설정을 하게 된다.

 

5K-1(config)# install feature-set fex                                                                  fex feature-set 설치

5K-1(config)# feature-set fex                                                                             fex feature-set 활성화

 

5K-1(config)# int e2/3-4

5K-1(config-if)# channel-group 52

5K-1(config-if)# no shutdown

 

5K-1(config)# int port 52

5K-1(config-if)# switchport mode fex-fabric                                                     InterfaceFex Mode 설정

5K-1(config-if)# fex associate 101                                                                     Fex  번호 설정(가상 슬롯 형태)

 

5K-1(config)# int e101/1/1                                                                                Fex Interface 설정

5K-1(config-if)# switchport mode access                      

5K-1(config-if)# switchport access vlan 10

    

 

 

 

 -  Port-Channel로 설정된 Fabric Interface의 정보

 

5K-1(config-if)# sh fex detail

FEX: 100 Description: FEX0100   state: Online

  FEX version: 5.2(1)N1(4) [Switch version: 5.2(1)N1(4)]

  FEX Interim version: 5.2(1)N1(4)

  Switch Interim version: 5.2(1)N1(4)

  ..

  pinning-mode: static    Max-links: 1

  Fabric port for control traffic: Eth1/7

   ..

  Fabric interface state:

    Po10 - Interface Up. State: Active  Port-Channel

    Eth1/7 - Interface Up. State: Active

    Eth1/8 - Interface Up. State: Active

  Fex Port        State  Fabric Port

       Eth100/1/1    Up        Po10

       Eth100/1/2    Up        Po10

       Eth100/1/3  Down        Po10

 

 

 

 

 

-  Port-Channel로 설정된 FEX에서 Fabric Interface가 Down된 경우, 전체적은 Port-Channel은 Up을 유지하고

   실제 Down된 Interface만 Down으로 체크된다. 하지만 각 Fabric Interface의 Port는 Port-channel로 연결되어 있기 때문에

   전체적인 하단 Interface는 기존 상태를 유지하게 된다.

 

5K-1(config)# sh fex 101 detail

FEX: 101 Description: FEX0101   state: Online

  Pinning-mode: static    Max-links: 1  Max Uplink 개수

  Fabric port for control traffic: Eth2/4  FEX Control Traffic 관리 포트

  

  Fabric interface state:  현재 Static PinningPort

   Po10 - Interface Up. State: Active  Port-Channel

    Eth2/3 - Interface Down. State: Configured

    Eth2/4 - Interface Up. State: Active 

Fex Port  State  Fabric Port

 Eth100/1/1      Up  Po10

 Eth100/1/2    Up  Po10

 Eth100/1/3    Down  Po10

 

 

 

 

FEX 설정 [Fabric Extender Type 설정]

   - Fabric Extender를 구성하기 전에, Pre-Provision 기능을 이용하여 아래와 같이 설정을 하게 되면 Fabric Extender를 연결하기 전에

     Fabric Extender Port 설정을 할 수 있다. .

   - , 사전에 설정한 Type과 맞지 않는 TypeFabric Extender를 연결 시에는 Type Mismatch로 사용할 수 없게 된다

 

5K-1(config)# fex 101

5K-1(config-fex)# type N2232TP                                                                           // FEX Type 사전에 설정하기

5K-1(config-if)# sh fex detail

FEX: 100 Description: FEX0100   state: Fex Type Mismatch 

  FEX version: 5.2(1)N1(4) [Switch version: 5.2(1)N1(4)]

  FEX Interim version: 5.2(1)N1(4)

  Switch Interim version: 5.2(1)N1(4)

  Extender Serial: SSI14280VS8

  Extender Model: N2K-C2248TP-1GE,  Part No: 73-12748-05                          // 실제 FEX Model

  Card Id: 99, Mac Addr: 58:8d:09:c9:41:02, Num Macs: 64

  Module Sw Gen: 12594  [Switch Sw Gen: 21]

  post level: complete

 pinning-mode: static    Max-links: 1

  Fabric port for control traffic: Eth1/7

  FCoE Admin: false

  FCoE Oper: true

  FCoE FEX AA Configured: false

  Fabric interface state:

    Po10 - Interface Up. State: Active

    Eth1/7 - Interface Up. State: Active

    Eth1/8 - Interface Up. State: Active

   ...

 

 

 

 

FEX 설정 [Fabric Extender Serial 설정]

   - FEX 연결 전에 연결할 Fabric Extender Serial을 지정하여 사전 설정을 할 수 있다.

   - , 사전에 설정한 Serial과 맞지 않는 TypeFabric Extender를 연결 시에는 Identity Mismatch로 사용할 수 없게 된다.

 

5K-1(config)# fex 101

5K-1(config-fex)# serial SSI14280VX  // FEX Serial 사전에 설정하기

5K-1(config-if)# sh fex detail

FEX: 100 Description: FEX0100   state: Discovered

  FEX version: 5.2(1)N1(4) [Switch version: 5.2(1)N1(4)]

  FEX Interim version: 5.2(1)N1(4)

  Switch Interim version: 5.2(1)N1(4)

  Extender Serial: SSI14280VS8

  Extender Model: N2K-C2248TP-1GE,  Part No: 73-12748-05

  Card Id: 99, Mac Addr: 58:8d:09:c9:41:02, Num Macs: 64

  Module Sw Gen: 12594  [Switch Sw Gen: 21]

  post level: complete

 pinning-mode: static    Max-links: 1

  Fabric port for control traffic:

  FCoE Admin: false

  FCoE Oper: true

  FCoE FEX AA Configured: false

  Fabric interface state:

    Po10 - Interface Down. State: Configured

    Eth1/7 - Interface Up. State: Identity-Mismatch

    Eth1/8 - Interface Up. State: Identity-Mismatch

  Fex Port        State  Fabric Port

       Eth100/1/1  Down        Po10

       Eth100/1/2  Down        Po10   ...

 

 

 

Posted by 네떡지기

Fabric Extender의 2번째 정리입니다.

지난 주부터 포스팅 주제를 좀 다양하게 하려다보니 기존 NX-OS 정리도 포스팅 텀이 생기지 않을까 싶네요. ^^;

(사실 기반 지식도 바닥(?)이 나는 것이기 때문이겠지만요. ^^;)

다음 NX-OS 포스팅은... Fabric Extender 3이 될지.. FabricPath를 이어서 할지.. ^^ 아직은 미정이지만..

곧 다시 또 올리도록 하겠습니다.

 


 

FEX 구성 방법

Nexus 2000은 개별 PortPinning을 하는 방법과 Port-Channel을 사용하는 2가지 Load-Balancing 방법이 있다

 

• Static Pinning

     - Front-panel PortUplink를 직접 구성하는 방법

     - Uplink의 구성 가능한 수를 기반으로 Pinning을 구성할 수 있다.

     - 모든 Host Interface는 하나의 Uplink에 할당이 되어야 한다.   

     - pinning max-links 명령을 통해서 각 Host Interface와 구성하는 Uplink의 수를 지정할 수 있다. [max-link : 1 ~ 4]

     - BandwidthOversubscription를 제어하는 데 있어서 좋은 구성 모드이다.

     - UplinkDown 경우에 DownLink에서 사용 가능한 Link로 자동 전환되지 않으며,

       삭제된 Uplink를 다시 추가하는 경우에도 재할당이 순서대로 되지는 않기 때문에 통신 상에 문제가 발생 할 수 있게 된다.

     - 재할당을 위해 DownUplink(Parent Switch Interface)에서 ‘no fex associate fex_nofex연결을 해제해주어야 한다

     - Fex 2148-T, 2148TP의 경우에는 1~4개의 Upstream Fabric Interface를 사용하며,

       Fex 2224TP1~2개의 Fabric Interface, Fex 2232PP1~8개의 Fabric Interface를 지원한다.

     -  해당 FEX와 연결된 Front-panel Port 확인 : show interface ethernet 1/17 fex-intf        

 

 

 

 

 

 

 

Ether-channel

     - Uplink Port가 하나의 논리적인 Interface로 구성(Port-channel)되어서, 모든 Front-panel portMapping 된다.

     - Uplink가 추가되거나 삭제될 때에도 Host Port는 그대로 Up 상태를 유지할 수 있다.

     - 모든 TrafficL2/L3 정보에 따라 Hash되어 Load Balancing되며, 하나의 UplinkFail된 경우에는 나머지 Link로 계속

       Load Balancing된다.

     - Host Interface에 대해서 L2 / L3 모두 각각 Standard Mode일 때에는 최대 8Interface, LACP Mode일 때에는 최대 16개의

       Interface 묶어서 구성할 수 있다

     - vPC를 이용하여 Uplink Port-channel을 구성할 수 있다.

 

 

 

 

FEX Static / Port Channel 차이

• StaticPortChannel의 차이를 이해하기 위해서는 Fabric Extender에 대한 컨셉의 기본 구조에 대해서 이해해야 한다.

     1. Fabric Extender는 중앙 SupervisorLine card를 연결하는 것과 유사한 방법이다.

     2. Fabric ExtenderLocal Switching을 하지 않고, 모든 SwitchingSupervisor에서 발생하게 된다.

• Static Pinning을 사용하는 경우에는 혼잡에 의해 영향을 받는 Server Port에 대해서 제어를 더 잘할 수 있다.

     Port ChannelTrafficHash에 의해서 Uplink로 보내지기 때문에 제어가 불가능하고,

     그래서 혼잡에 의해서 Host에 영향을 어떻게 받을지에 대해서 예측이 어렵다.

• Static PinningHost별로 직접 Port 지정이 가능하기 때문에 사용량에 따라 혼잡이 발생하지 않도록 Port 구성을 분배할 수 있으나,

     PortChannel의 경우에는 Hash 함수에 의해 자동지정이기 때문에 Port 구성 분배를 지정할 수 없기 때문에 특정 Port에 혼잡이 발생

    하면서 다른 Port는 여유대역폭이 남을 수 있다.

 • Static Pinning의 경우에는 Fabric Link중에 하나가 문제가 발생할 경우를 대비하기 위해서, Host 단에서 이중화(NIC Teaming같은)

    해두어야  하지만, Port-channelFabric Link중에 하나가 문제가 발생하더라도 나머지 Link로 전송이 가능하기 때문에 별도의 Host

    이중화를 하지 않더라도 통신이 가능하다.

    * Host단을 이중화로 구성한 경우,  상단 Static PinningUplink Down 시에 해당 Host InterfaceDown되어 Host단의 Fail-over

       된다.

 

 

 

FEX 구성 Topology

 

 

 

 

Enhanced Virtual PortChannel

• NX-OS 5.2(1)부터 Fabric Extender에서 host vPC를 서로 다른 FEX 통해 vPC 설정이 가능하다.

• Enhanced vPCHost에서 FEX FEX에서 Nexus 5500으로의 모든 구간을 Active 구간으로 만들어서,

   사용 가능한 Bandwidth를 효율화 한다.

지원 가능 플랫폼 (NX-OS 5.1.(3)N1(1))

     - Nexus 5548P / 5548UP / 5596UP (지원)

     - Nexus 5010 / 5020 (지원 불가)

Single Homed 구성은 Host802.3ad(LACP) 지원 가능 시, Dual-Homed802.3ad(LACP) 지원 불가능 시에 A/S 구조로 사용한다

 

 

Posted by 네떡지기

티스토리 툴바