Last Update 13.01.23 (Bridge Assurance)

 

또, 정신없이 시간이 흘러가네요. ^^;

정리가 자꾸 더뎌지네요... 오늘은 기존에 정리했던 내용 중에 좀 더 마무리를 지으려던 내용 중에 우선 일부 올립니다. ^^

추가적인 보완은 계속 해 나가야 할 듯 싶네요. ^^

 

 

 


 

STP

• NX-OSRapid-PVST+ DefaultEnable되어 있다.

• Rapid-PVSTMST와 상호 운용된다. (Default Enable)

• STP extended system-id가 항상 Enable 상태이다. (IOS에서는 Spanning-tree extend system-id 명령이  필요)

• BPDU GuardLoop Guard, Root Guard, BPDU Filter 기능을 지원한다.

• VDC별로 오직 하나의 STP만 활성화가 가능하다.

현재 구성된 L2 구성상에 STP가 필요하지 않더라도 STPDisable하지 않아야 한다. (Configuration이나 Cabling Error의 방지)

기존 IOS Command와 사용은 동일하다.

• MST에서 VLANMAC은 동일한  Instance 간에는 동일하다

 

 

Spanning-Tree Port Type

• Normal ports : 기본 Port Type이다.

• Network ports : Bridges 사이에 설정되며, Bridge AssuranceDefaultEnable된다.

• Edge ports : 이전의 PortFast와 같다. L2 Loop를 발생하지 않는 종단 장비에만 설정되어야 한다

 

 

Virtualization Hosts

최근 데이터센터의 가상화에 따라서 두 가지의 Interface Type이 혼용될 수 있다.

• 802.1Q Trunk는 원래 네트워크 장비 간을 위해서 사용되지만, 가상화 Host가 연결된 포트에서도 사용되야 한다.

   하지만, 이 경우에 실제 물리적으로 1대의 장비이기 때문에 Edge 설정을 통해서, 바로 동작할 수 있도록 해주는 것이 좋다

 

  NX-OS(config-if)# spanning-tree port type edge trunk

 

 

Bridge Assurance

• Spanning-Tree 오동작에 의한 Loop를 제거할 수 있는 새로운 기술로, 다음과 같은 문제점을 해결할 수 있다.

 

      -  Unidirectional link failure (단방향 링크 문제)

      -  Software failure (Control Plane 비정상/Data Plane 정상 시, Blocking PortForwarding 상태로 되면서 Loop 발생 가능)

모든 Port는 현재 상태와 상관없이 모든 VLANBPDU를 주고 받는다.

  일반적으로 STP에서는  BPDURoot로부터 다른 Switch로의 전송이 되지만,  Bridge Assurance가 활성화 되면 모든 Port

   현재의 상태  상관없이 모든 VLANBPDU를 주고 받는다.

• BPDU를 사용하여 양방향 Keepalive를 확인하여, BPDU의 수신이 끊기는 포트의 전송상태는 Inconsistent 로 된다.

  이러한 기능을 통해서 Bridge 오동작에 의한 Loop를 방지할 수 있다.

• Rapid PVST+ MST에서만 지원된다.

양 쪽 장비 모두에서 설정이 되어야 있어야만 하며, 그렇지 않을 경우에 연결된 PortBlock 상태가 된다.

Bridge AssuranceSpanning Tree Port 상태가 Network Type인 경우  기본적으로 Enable 상태이다. 

다음 명령을 통해서 bridge assuranceGlobally mode에서 비활성화 시킬 수 있으며,

  또한 포트에서 Spanning-Tree port type의 설정을 통해서 활성화 할 수 있다.

Loopguard와 유사한 동작을 수행하지만, loopguard의 경우에는 현재 차단된 포트에서 BPDU 수신시에만 동작한다.

   또한 동일한 Port에서는 LoopGuardBridge Assurance 중의 하나만 사용이 가능하다.

 

  NX-OS(config)# no spanning-tree bridge assurance                            : 전체 비활성화

  NX-OS(config-if)# spanning-tree port type network                            : 포트별 활성화

 

 

 

 

 

Nexus_정리자료(STP_BA).pdf

 

Posted by 네떡지기
분류없음2012.06.16 00:00

NX-OS License.

• Grace period

   -  특정 Feature 지원하는 License를 구입하기 전에, 테스트를 위해서 Nexus의 모든 기능을 활성화할 수 있게 하는 기간.

      Grace period가 만료되면, 구입하지 않은 License와 관련된 모든 Configuration은 자동 삭제가 된다.  [ 120 ]

   -  Grace period은 기본 계정에 대해서만 사용이 가능하다

 

Posted by 네떡지기

Last Update 2014.04.03

 


안녕하세요 

 

Nexus , NX-OS의 5번째 정리내용은 Nexus에서 기존 Port-Channel 기술의 Upgrade 버전인, vPC (virtual Port-Channel)입니다.

 

내용 중에 미흡한 부분도 있을 수 있구요. 혹여나 제가 잘못 이해한 부분이 있을 수 있습니다.

 

그런 경우에는 주저하지 마시고~ 반드시 꼭 댓글 부탁드립니다.

 


 

vPC (Virtual Port Channels)

• vPC는 서로 다른 장비에서 연결된 Port를 묶어서 논리적인 하나의 포트로 인식하게 하는 기존 Port-Channel의 확장된 개념

    - 기존 Port-ChannelLayler-2, Layer-3 모두 설정 가능하지만, vPCLayer-2만 가능하다.

• Spanning Tree를 사용하는 기존의 Port-Channel보다 빠른 Convergence가 가능하다.

• Loop-freeTopology를 제공하기 때문에 Spanning-TreeBlocked Port를 제거할 수 있다.

• feature 명령을 통해서 vPC를 활성화 시켜줘야 한다.

• vPC Domain은 단일 VDC에서만 동작하기 때문에, 반드시 동일한 VDC에서 vPC Domain 선언을 해야한다.

vPCvPC Domain을 통해서, Nexus 장비 간의 연결을 하며, vPC Domain 아래 2개의 특별한 Link를 통해 vPC peers간의 정

  보를 교환한다

    - vPC peer-keepalive link

          : vPC Peer간의 Heartbeating을 제공하여, 장비 간의 Online 상태 확인 vPC 구조에서의 Loop 발생을 피하게 한다.

    - vPC peer link

          : vPC Peer 간의 정보를 교환.

          : vPC Peer-linkLayer 2 port channels(trunk)로 구성하는 것을 권고함.

            ※ vPC peer link 반드시 10GbE Port여야 하며,  서로 다른 2개의 모듈의 포트에 할당해서 설정하도록 한다.

          : 같은 종류의 Line Card간만 구성이 가능하다.          

            Ex) M1 ↔ M1 / F1  ↔  F1 / F2 ↔ F2  [ 구성 가능 ]     

                 M1 ↔ F1 /  M1 ↔ F2 / F1 ↔ F2   [ 구성 불가능 ]

• 서로 다른 장비에서 가상의 vPC를 구성하는 Port-Channel의 Port를 Member Port라고 한다.

    - vPC Member Port

           : NX-OS(config-if) vpc <vpc id>

           : vPC Peer간의 설정이 동일 해야하만 한다. 동일하지 않을 경우 전체 Port가 suspend될 수 있다. (일관성 체크)

           : vPC ID와 Port-Channel ID를 동일하게 구성하는 것이 설정/모니터링/장애처리에 쉽다.

           : 같은 종류의 Line Card간만 구성이 가능하다.          

            Ex) M1 ↔ M1 / F1  ↔  F1 / F2 ↔ F2  [ 구성 가능 ]     

                 M1 ↔ F1 /  M1 ↔ F2 / F1 ↔ F2   [ 구성 불가능 ]

• Cisco Fabric Services (CFS) 자동으로 enable되어, vPC Peer Link를 통해 IGMP, STP, MAC-address-table를 동기화 한다.

 

 

 

peer-keepalive link

• peer-keepalive linkmanagement interface(MGMT0)이나 Switched Virtual Interface(SVI)로 구성이 가능.

• peer-keepalive link는 별도의 VRF사용하여  vPC peer간의 Lavyer 3 인터페이스로 구성하는 것을 권고함.

    - 별도의 VRF를 구성하지 않으면,  시스템에서는 management VRF를 사용함. (Default)

• peer-keepalive link를 관리인터페이스(mgmt0)을 사용할 경우에는, peer 장비에서 Active SupervisiorStandby Supervisior

  각 mgmt0 management switch를 구성해서 연결해야 한다. 

    - mgmt0인터페이스에 직접 바로 연결을 하게 되면, 하드웨어 Fail로 인한 Supervisor switchover,

      In-Service Software Upgrade(ISSU) 동안 mgmt0 인터페이스가 변경됨에 따라서,  keepalive messages  중단될 수 있다.

 

                                 

Mgmt0 인터페이스에 Management Switch를 연결하여 Keepalive-link 구성

 

 

• vPC Peer link를 설정하기 전에 peer-keepalive를 구성해야 한다.

    - 미 구성 시, vPC peer linkpeer linkUp 되지 않는다.

 

 

 

== vPC 설정해보기 예제 ==

 

 

 

 

vPC 설정 (1번기)

 

NX-OS(Config)# feature vpc

 

NX-OS(Config)# vrf context vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/2, 2/2

NX-OS(Config-if)# channel-group 1

 

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# vrf member vPC_Keepalive

NX-OS(Config-if)# ip address 1.1.1.1/30

 

NX-OS(Config)# vpc domain 1

NX-OS(Config-vpc-domain)# peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/1, 2/1

NX-OS(Config-if)# switchport

NX-OS(Config-if)# switchport mode trunk

NX-OS(Config-if)# channel-group 2

 

NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)#  vpc peer-link

 

NX-OS(Config)# interface Ethernet 7/1

NX-OS(Config-if)# channel-group 5 mode active

NX-OS(Config)# interface port-channel 5

NX-OS(Config-if)#  vpc 5

 

NX-OS(Config)# interface Ethernet 7/2

NX-OS(Config-if)# channel-group 6 mode active

NX-OS(Config)# interface port-channel 6

NX-OS(Config-if)#  vpc 6

 

먼저 vPC를 사용하기 위한 feature를 활성화하고, vPC를 구성하는 장비 간의 KeepAlive Link를 구성한다.

그리고 vPC Domain에서 KeepAlive 설정을 하고, vPC 구성 장비(Peer)간의 정보 교환을 위한 Peer Link를 구성한다.

KeepAlive Link와 Peer Link를 모두 구성한 후에는 Port-Channel 생성과 동일하게 Port-Channel 생성 후에

Port-Channel Interface에 vPC를 설정한다.

 

 

 

vPC 설정 (2번기)

 

NX-OS(Config)# feature vpc

 

NX-OS(Config)# vrf context vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/2, 2/2

NX-OS(Config-if)# channel-group 1

 

NX-OS(Config)# interface port-channel 1

NX-OS(Config-if)# vrf member vPC_Keepalive

NX-OS(Config-if)# ip address 1.1.1.2/30

 

NX-OS(Config)# vpc domain 1

NX-OS(Config-vpc-domain)# peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf vPC_Keepalive

 

NX-OS(Config)# interface Ethernet1/1, 2/1

NX-OS(Config-if)# switchport

NX-OS(Config-if)# switchport mode trunk

NX-OS(Config-if)# channel-group 2

 

NX-OS(Config)# interface port-channel 2

NX-OS(Config-if)#  vpc peer-link

 

NX-OS(Config)# interface Ethernet 7/2

NX-OS(Config-if)# channel-group 5 mode active

NX-OS(Config)# interface port-channel 5

NX-OS(Config-if)#  vpc 5

 

NX-OS(Config)# interface Ethernet 7/1

NX-OS(Config-if)# channel-group 6 mode active

NX-OS(Config)# interface port-channel 6

NX-OS(Config-if)#  vpc 6

 

 

 

 

Nexus_정리자료(vPC)update0612.pdf

Posted by 네떡지기

Nexus 4번째 정리입니다.

핑계 없는 무덤은 없다지만, 자주 업데이트를 하지를 못하고 있네요.

딱히 특정 챕터 중심이라기 보다는 제가 정리되는 순서대로 업데이트하다보니 내용 또한 중구난방입니다.

이 점 양해 부탁드리며~ 혹시 잘못된 부분이 있으면 알려주세요

 

 


Last Updated 2015. 01. 22. - High Availability

Updated 2013. 01. 23 - Port Profile


 

High Availability 정책

• VDC crashes 발생할 경우에 VDC고가용성 보장하기 위해서 VDC의 종류와 Supervisor(single/dual)에 다음과 같이 동작한다.

• Default VDC (Default VDC 혹은 Admin VDC의 경우는 정책 변경 불가)

      - Dual-supervisor : Switchover  - Single-supervisor : Reload

• Non-default VDC

      - Restart : VDC의 모든 내용을 초기화 하고, Startup configuration을 사용하여 새로 만든다. (Auto)

      - Bringdown : VDCfailed 상태로 전환한다.  Failed 상태를 복구하기 위해서는 수동으로 VDC나 장비를 Reload해야 한다.

      - Switchover : Active Supervisor을 전환 /  Dual-Supervisor 인 경우에만 설정 가능 

      - Reload(reset) : Super-visorReload(Reset) .  /  Single-Supervisor 인 경우에만 설정 가능

위와 같은 동작 방식은 Default VDC에서는 따로 설정할 필요가 없으나, Non-default VDC에서는 동작 방식을 설정해야 한다.

• High Availability 정책 설정 및 확인은 다음과 같이 할 수 있다.

 

 

 

Port-Profile 적용

NX-OS# show vdc detail

Switchwide mode is m1 f1 m1xl f2 m2xl f2e f3

vdc id: 1                                                                                                 : Default VDC

vdc name: NX-OS-VDC1

vdc state: active

vdc mac address: e4:c7:22:65:96:41

vdc ha policy: RELOAD

vdc dual-sup ha policy: SWITCHOVER

vdc boot Order: 1

CPU Share: 5

CPU Share Percentage: 25%

vdc create time: Thu Jun 19 03:44:46 2014

vdc reload count: 0

vdc uptime: 121 day(s), 21 hour(s), 11 minute(s), 18 second(s)

vdc restart count: 0

vdc type: Ethernet

vdc supported linecards: m1 m1xl m2xl f2e

vdc id: 2                                                                                                  : Non-Default VDC

vdc name: NX-OS-VDC2

vdc state: active

vdc mac address: e4:c7:22:65:96:42

vdc ha policy: RESTART

vdc dual-sup ha policy: SWITCHOVER

vdc boot Order: 1

CPU Share: 5

CPU Share Percentage: 25%

vdc create time: Thu Jun 19 03:48:15 2014

vdc reload count: 0

vdc uptime: 121 day(s), 21 hour(s), 7 minute(s), 57 second(s)

vdc restart count: 0

vdc type: Ethernet

vdc supported linecards: m1 m1xl m2xl f2e

 

 

 


Supervisior Redundancy

• Supervisior Module Active/Standby HA(High Availability) 상태 확인

     - NX-OS#  show system redundancy status

Supervisior ModuleActive/Standby 상태를 전환

     - NX-OS#  system switchover

 

 

 

 

 


Port-Profile

다수의 Interface에 동일한 Config 해야할 때, 설정해야 하는 ConfigProfile 형식으로 만들어 해당 설정을 적용해야 하는

  Interface 단순히 해당 Profile을 적용하여 Interface 설정을 손쉽게 하는 데 사용이 가능하

다수의 Interface에 동일한 Config 해야할, 설정해야 하는 ConfigProfile 형식으로 만들어 해당 설정을 적용해야 하는 Interface

  단순히 해당 Profile을 적용하여 Interface 설정을 손쉽게 하는 데 사용이 가능하다.

• Ethernet, VLAN or Port channel interface에 대해서 지원

하나의 Port-Profile은 상속되어서, 다른 Profile에서도 사용이 가능하다.  즉 계층적인 Profile을 구성 가능하다.

  이러한 계층적인 Profile 구성은 총 4단계의 계층으로 구성이 가능하지만,

   switchport private-vlan mappingprivate-vlan mapping

  명령을 사용 시에는 오직 1단계 계층으로만 구성이 가능하다.  (TEST 해볼 것)

반드시 해당 Port-Profilestate enable을 해주어야 해당 Port-Profile을 사용할 수 있다.

      - 사용 중, state disable시에는 해당 Port-Profile을 사용 중인 Port는 사용 불가.

• Port ProfileTypeInterface mode(Layer2, Layer3)은 동일하게 구성을 해야 한다.

 

• Port-Profile 수정 시에, 할당된 Port의 정보도 함께 Update.

 

Port-Profile 적용

 NX-OS(config)# port-profile type ethernet My_PortConfig

 NX-OS(config-port-prof)# switchport

 NX-OS(config-port-prof)# switchport access vlan 7

 NX-OS(config-port-prof)# spanning-tree port type edge

 NX-OS(config-port-prof)# spanning-tree bpduguard enable

 NX-OS(config-ppm)# state enable

 NX-OS(config)# interface ethernet 1/1-2

 NX-OS(config-if-range)# inherit port-profile My_PortConfig

 NX-OS# sh run int e 1/1

 ! Command: show running-config interface Ethernet1/1

 !Time: Tue Jun  5 21:28:25 2012

 version 6.0(1)

 interface Ethernet1/1

   inherit port-profile My_PortConfig

 NX-OS#

 

 

 Port-Profile 확인

 NX-OS# sh port-profile brief 

 ---------------------------------------------------------------

 Port                Profile  Conf   Eval   Assigned  Child

 Profile              State   Items  Items  Intfs       Profs

 --------------------------------------------------------------

 My_PortConfig       1        4      4      2           0

 NX-OS# sh port-profile name My_PortConfig

 port-profile My_PortConfig

  type: Ethernet

  description:

  status: enabled

  max-ports: 512

  inherit:

  config attributes:

   switchport

   switchport access vlan 7

   spanning-tree port type edge

   spanning-tree bpduguard enable

  evaluated config attributes:

   switchport

   switchport access vlan 7

   spanning-tree port type edge

   spanning-tree bpduguard enable

  assigned interfaces:

   Ethernet1/1

   Ethernet1/2

 NX-OS#

 

 

 

Nexus_정리자료(Supervisior Redundancy_PortProfile).pdf

 

Posted by 네떡지기

어제에 이어서 올리는 Nexus 정리 3번째 입니다.

이번에는 Configuration을 특정시점에 기록하고, 복구할 수 있는 기능인 Checkpoint와 Rollback에 대한 정리입니다.

 

Nexus_정리자료(Checkpoint_Rollback).pdf

 


Checkpoint / Rollback

• Nexus에서 Config 변경 작업 시에, 작업 전 시점에서 Checkpoint 명령어를 사용하여 현재 Running-Config  시점을 기록

  하고 Config 작업 전으로 원상복구가 필요한 경우에 Rollback 명령을 이용해서 , Checkpoint에서 지정한 시점으로 복구할

  수 있다.

     - NX-OS(config)# checkpoint Checkpoint_NAME [desc desctription ]

     - NX-OS(config)# rollback running-config checkpoint Checkpoint_NAME  [option ]

다음의 3가지 경우에는 시스템에서 자동적으로 Checkpoint생성한다.

     - no feature 명령을 사용 특정 feature 제거했을 경우

     - Layer-3 프로토콜 Feature 제거했을 경우 ( Ex : no feature ospf )

     - feature 대한 Grace-period 라이센스가 만료되었을 경우.

 

 

Checkpoint Guidelines.

Checkpoint Exec 모드에서 생성되며, 오직 1명의 사용자만VDC별로번에 Checkpoint수행할있다.

VDC별로 최대 10개의 Checkpoint생성할있으며, 추가적으로 file 옵션 사용,  Bootflash volatile memory

   File 생성이 가능하다

Checkpoint 내부 저장소에 저장되며, Common User 접근이 불가능하다.

Checkpoint 영구적이며, Redundant Supervisior간의 동기화된다

• Checkpoint names 최대 80자까지 공백없이 사용 가능하며, descriptions 공백을 포함한 최대 80자까지 사용 할 수 있다.

show diff rollback-patch 명령을 사용하여 checkpoints, files, starup-configuration, running-configuration 비교할있다.

clear checkpoint database 또는 write erase 명령을 통해서 모든 Checkpoint 파일을 삭제할있다.

 

 

Checkpoint 시점 생성 및 Config 변경 테스트

 NX-OS#  sh run int e2/15

 !Command: show running-config interface Ethernet2/15

 interface Ethernet2/15

 NX-OS#  checkpoint My_Work_Point desc TestCheck

 Done

 NX-OS# conf t

 Enter configuration commands, one per line.  End with CNTL/Z.

 NX-OS(config)# int e2/15

 NX-OS config-if)# switchport

 NX-OS(config-if)# switchport access vlan 120

 NX-OS(config-if)# sh run int e2/15

 interface Ethernet2/15

   switchport

   switchport access vlan 120

 NX-OS(config-if)#

     § 최초에 ethernet e2/15에는 아무런 설정이 되어 있지 않은 것을 확인하고, 그 상태에서 checkpoint를 사용해서 현재 시점에 대한 설정을 저장 후에, ethernet e2/15에 설정을 변경한다.

 

Config Rollback 및 확인

 NX-OS# rollback running-config checkpoint My_Work_Point verbose

 Note: Applying config parallelly may fail Rollback verification

 Collecting Running-Config

 #Generating Rollback Patch

 Executing Rollback Patch

 ========================================================

 `conf t`

 `interface Ethernet2/15`

 `no switchport access vlan`

 `no switchport`

 `exit`

 `interface Ethernet2/15`

 `no switchport`

 ========================================================

 Generating Running-config for verification

 Generating Patch for verification

 Verification is Sucessful.

 Rollback completed successfully.

 NX-OS# sh run int e2/15

 version 6.0(1)

 interface Ethernet2/15

 NX-OS#

     § Checkpoint로 만든 시점으로 config를 원복하기 위해서 rollback을 사용하여 설정을 복구한다.

 

 Checkpoint 확인 및 삭제하기

 

 NX-OS # show checkpoint summary user

 User Checkpoint Summary

 --------------------------------------------------------------------------------

 1) My_Work_Point:

 Created by sadmin

 Created at Sun, 14:07:37 27 May 2012

 Size is 6,554 bytes

 Description: TestCheck

 NX-OS# clear checkpoint database user

 .......Done

 NX-OS# show checkpoint summary user

 NX-OS#

     § Checkpoint를 확인하고, Checkpoint를 삭제하는 것이다. 여기에서는 system에서 자동으로 생성된 checkpoint가 아닌 사용자에 의해서 생성된 user에 대한 checkpoint만 확인 및 삭제하였다.

Posted by 네떡지기

Nexus 두 번째 정리자료입니다.

내용상으로 보면, 이게 제일 먼저 올릴 법한 자료인 VDC에 관한 아주 간략한 내용입니다만,

자료 보는 순서와, 정리가 된 순서대로 하다보니 이렇게 됐네요.

(L2 관련 부분을 먼저 정리하기 시작했는데, 딱히 자료가 정리가 되지를 않아서..)

 

내용은 많지는 않지만, 자꾸 더디게 정리가 되서 우선 정리되는데로 올려보려고 짧게 끊어서라도

조금 빈번하게 올려보려고 합니다.

 

첨부파일(PDF)로도 첨부합니다.

 

=================================================================================================================

 

NX-OS : VDC

 

◈ VDC 관련 기본 정리

  Nexus 7000에서의 최대 VDC4개까지 생성이 가능하다. 

  장비의 최초 접속 시에는 default VDC로 접속하게 된다.. 

  VDC별로 Interface를 할당하여 사용을 하며, VDC 간의 통신을 위해서 VDC에 할당된 Interface를 직접 연결하지 않는 이상

   통신이 불가

 VDC는 독립적인 Configuration,  Software Process가 동작한다.

  VDCVDC별로 유일한 namespace로 구분을 할 수 있으며, VDC별로  Resource를 할당할 수 있다.

  VDC별로 Reload가 가능하지만, Default VDC는 전체 VDC에 영향을 미치기 떄문에 독립적인 Reload가 불가능하다.

  VDC에 대한 정보를 Default VDC에서 확인 시에는 전체 VDC에 대한 정보를 확인할 수 있지만, 특정 VDC로 이동하여 동일한

   명령어로 VDC 정보 확인 시에는, 현재 VDC에 대한 정보만 볼 수 있다

 

 

◈ VDC 관련 기본 설정 및 확인

 

VDC 생성 및 확인

 NX-OS(config)# vdc NW-ZIGI

 Note:  VDC creation is a time consuming process, please wait until the command completes

 NX-OS# show vdc

 vdc_id    vdc_name                     state               mac                     type           lc     

 ------     --------                          -----               ----------              ---------     ------ 

 1           NX-OS                         active              00:26:98:0d:19:41    Ethernet    m1 f1 m1xl

 2           NW-ZIGI                       active               00:26:98:0d:19:42    Ethernet    m1 f1 m1xl

§ VDC VDC_NAME 명령을 통해서 새로운 VDC를 생성할 수 있다.

  이 때 VDC 생성 시 사용한 VDC_NAME으로 VDC 관련 Config에서 각 VDC를 구분하게 된다.

 

VDC  Interface 할당 및 확인

 NX-OS(config)# vdc NW-ZIGI

 NX-OS(config-vdc)# allocate interface Ethernet1/4

 NX-OS(config-vdc)# allocate interface Ethernet1/5

 NX-OS(config-vdc)# show vdc membership

 vdc_id: 1 vdc_name: NX-OS interfaces:

          Ethernet1/1     Ethernet1/2 Ethernet1/3

 vdc_id: 2 vdc_name: NW-ZIGI interfaces:

          Ethernet1/4     Ethernet1/5

§ 각 VDC에서 사용하게 된 Interface는 해당 VDC에 할당한 후에 사용 가능하며,

  show vdc membership 명령어를 이용해서 각 VDC에 할당된 Interface 정보를 확인할 수 있다.

 

 

VDC  Resource 할당  

 NX-OS(config)# vdc NW-ZIGI

 NX-OS(config-vdc)# limit-resource port-channel minimum 32 maximum equal-to-min

 NX-OS(config-vdc)# limit-resource u4route-mem minimum 32 maximum equal-to-min

 NX-OS(config-vdc)# limit-resource u6route-mem minimum 32 maximum equal-to-min

 NX-OS(config-vdc)# limit-resource vlan minimum 32 maximum equal-to-min

 NX-OS(config-vdc)# limit-resource vrf minimum 32 maximum equal-to-min

§ VDC별로 Resourece를 어떻게 할당할 것인지에 대한 부분을 VDC별로 지정할 수 있다.

 

 

VDC 간의 이동 및 현재 VDC 확인

 NX-OS# switchto vdc ?

      NW-ZIGI         VDC number 2

      NX-OS            VDC number 1

 NX-OS # switchto vdc NW-ZIGI

 NW-ZIGI # show vdc current-vdc

 Current vdc is 2 - NW-ZIGI

§ 최초의 접속 시에는 Default VDC(VDC_ID : 1)로 접속하고, 각 VDC로 이동하기 위해서는

   switchto vdc VDC_NAME 명령어를 이용해서 이동할 수 있다.

 

 

Default VDC로 복귀

 NW-ZIGI # switchback   ( or exit )

 NX-OS  

§ 다른 VDC에서 Default VDC로 이동하기 위해서는 switchback 명령이나 exit 명령어를 사용하면 된다.

 

 

Non-VDC Reload

 NX-OS # reload vdc NW-ZIGI

 Are you sure you want to reload this vdc (y/n)?  [no] y

 NX-OS %$ VDC-1 %$ %VDC_MGR-2-VDC_OFFLINE: vdc 2 is now offline

 NX-OS %$ VDC-1 %$ %VDC_MGR-2-VDC_ONLINE: vdc 2 has come

§ Nexus는 Default VDC가 아닌 Non-VDC에 대해서는 VDC별로 Reload가 가능하다.

  해당 VDC이외에 다른 VDC에는 따라서 영향이 없다.   VDC별 Reload는 reload vdc VDC_NAME 명령어를 사용한다.

 

 ※ 전체 시스템을 Reload 할 경우에는 10분정도 소요되지만, VDC별 Reload 시에는 1분정도가 소요된다.

 

 

Nexus_정리자료(VDC).pdf

 

Posted by 네떡지기

자주 글을 올리려고 해도 오랜만에 글을 올리게 되네요.

 

Cisco Nexus를 도입하게 되면서, 기존 운영하고 있는 부분과 관련된 부분을 한글화 자료로 만드는 중입니다.

 

우선 저는 EIGRP랑 OSPF, HSRP 부분만 정리를 하게 되서 블로그에 올려봅니다.

 

기본적인 내용과 IOS와 NX-OS상의 다른 Command를 올렸습니다.

 

아직 공부 중인 내용이라서, 좀 틀린 부분이 있을 수도 있으니 그런 부분을 발견해주시면 댓글을 남겨주세요.

 

저도 수정하고 공부하도록 하겠습니다.

 

 

 

 

 

 

 

 

 

 

 

 

 

Nexus_EIGRP_OSPF_HSRP_정리v0.5.pdf

Posted by 네떡지기

티스토리 툴바