==== router - switch (trunk) ====
sw
interface fa0/1
switchprot trunk encapsulation dot1q (isl)
switchport mode trunk
router
interface fa0/0
no shutdown
interface fa0/0.2
encapsulation dot1q 2
ip address 10.1.2.1 255.255.255.0
interface fa0/0.3
encapsulation dot1q 3
ip address 10.1.3.1 255.255.255.0
====== multilayer switch ======
interface fa1/2
switchport access vlan 2
interface vlan 2 (SVI)= L3
ip add 10.1.2.1 255.255.255.0
interface fa1/3
switchport access vlan 3
interface vlan 3 (SVI)= L3
ip add 10.1.3.1 255.255.255.0
===== Multilayer Switch =====
1. L2 (vlan 할당)
2. L3 (no switchport)
3. SVI (interface vlan x)
4. routing protocol (ip routing)
L3 (show ip route) routing table (0, 1, either)
L2 (show mac-address-table) mac-address table (0, 1)
=== L3 ===
1. control plane (routing table) software
2. data plane (packet forwarding) hardware
===L3 Switching===
1. process switching (data plane => control plane => data plane)
2. fast switching (first packet process switching)
3. FIB (CEF)
control plane ==> routing table (show ip route)
data plane ==> FIB (CEF) table (show ip cef)
control plane (routing table) show ip route
data plane (FIB, ADJ) show ip cef(FIB), show ip adj(L2 L3 mapping)